bug#24807: Bug

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

bug#24807: Bug

夢巫子 (Yumiko)
$ autoreconf -if
aclocal-1.15: overwriting 'm4/ax_cxx_compile_stdcxx.m4' \
 with '/usr/share/aclocal/ax_cxx_compile_stdcxx.m4'
aclocal-1.15: overwriting 'm4/ax_cxx_compile_stdcxx_11.m4' \
 with '/usr/share/aclocal/ax_cxx_compile_stdcxx_11.m4'
aclocal-1.15: installing 'm4/ax_require_defined.m4' \
 from '/usr/share/aclocal/ax_require_defined.m4'
aclocal-1.15: error: too many loops
aclocal-1.15: Please contact <[hidden email]>.
 at /usr/share/automake-1.15/Automake/Channels.pm line 662.
        Automake::Channels::msg("automake", "", "too many loops") \
   called at /usr/share/automake-1.15/Automake/ChannelDefs.pm line 212
        Automake::ChannelDefs::prog_error("too many loops") \
   called at /usr/bin/aclocal-1.15 line 1188
autoreconf-2.69: aclocal failed with exit status: 255

automake-1.15
autoconf (GNU Autoconf) 2.69

My system is Gentoo Linux. There might be patches.
Starting autoreconf again with the same arguments finishes without
errors. Shell is ZSH.

configure.ac and Makefile.am are simple. Do you need them?

signature.asc (817 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

bug#24807: Bug

Mathieu Lirzin
Hello,

夢巫子 (Yumiko) <[hidden email]> writes:

> $ autoreconf -if
> aclocal-1.15: overwriting 'm4/ax_cxx_compile_stdcxx.m4' \
>  with '/usr/share/aclocal/ax_cxx_compile_stdcxx.m4'
> aclocal-1.15: overwriting 'm4/ax_cxx_compile_stdcxx_11.m4' \
>  with '/usr/share/aclocal/ax_cxx_compile_stdcxx_11.m4'
> aclocal-1.15: installing 'm4/ax_require_defined.m4' \
>  from '/usr/share/aclocal/ax_require_defined.m4'
> aclocal-1.15: error: too many loops
> aclocal-1.15: Please contact <[hidden email]>.
>  at /usr/share/automake-1.15/Automake/Channels.pm line 662.
> Automake::Channels::msg("automake", "", "too many loops") \
>    called at /usr/share/automake-1.15/Automake/ChannelDefs.pm line 212
> Automake::ChannelDefs::prog_error("too many loops") \
>    called at /usr/bin/aclocal-1.15 line 1188
> autoreconf-2.69: aclocal failed with exit status: 255
>
> automake-1.15
> autoconf (GNU Autoconf) 2.69
>
> My system is Gentoo Linux. There might be patches.
> Starting autoreconf again with the same arguments finishes without
> errors. Shell is ZSH.
>
> configure.ac and Makefile.am are simple. Do you need them?

The issue seems to come from a bad interaction between aclocal and the
macros from the Autoconf Archive (m4/ax_....m4)

Can you recheck if the issue is still valid with Automake 1.15.1 and the
latest version of those macros from the autoconf archive?

If the issue is still here, a tarball including those macros and a
minimal example would help us debbuging it.

Thank you for the bug report.

--
Mathieu Lirzin
GPG: F2A3 8D7E EB2B 6640 5761  070D 0ADE E100 9460 4D37