bug#23768: [PATCH] tests: adjust to ignore gzip 1.8+ warnings

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

bug#23768: [PATCH] tests: adjust to ignore gzip 1.8+ warnings

Hans-Bernhard Bröker
Am 14.06.2016 um 09:48 schrieb Ludovic Courtès:
> -test ! -s stderr
> +
> +# Gzip 1.8+ emits warnings like "gzip: warning: GZIP environment
> +# variable is deprecated"; filter them out.
> +test `grep -v '^gzip: warning' stderr | wc -l` -eq 0

Hmmm... wouldn't it make much more sense to just eliminate the GZIP
environment variable, if set?