bug#23639: Half bug

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

bug#23639: Half bug

Alexandre Sanches
alex@ursula ~/devel/test $ ls
configure.ac  include  m4  Makefile.am  src
alex@ursula ~/devel/test $ autoreconf -fi
aclocal-1.15: installing 'm4/ax_cxx_compile_stdcxx.m4' from
'/usr/share/aclocal/ax_cxx_compile_stdcxx.m4'
aclocal-1.15: installing 'm4/ax_cxx_compile_stdcxx_14.m4' from
'/usr/share/aclocal/ax_cxx_compile_stdcxx_14.m4'
aclocal-1.15: installing 'm4/ax_require_defined.m4' from
'/usr/share/aclocal/ax_require_defined.m4'
aclocal-1.15: error: too many loops
aclocal-1.15: Please contact <[hidden email]>.
 at /usr/share/automake-1.15/Automake/Channels.pm line 662.
        Automake::Channels::msg("automake", "", "too many loops") called at
/usr/share/automake-1.15/Automake/ChannelDefs.pm line 212
        Automake::ChannelDefs::prog_error("too many loops") called at
/usr/bin/aclocal-1.15 line 1188
autoreconf-2.69: aclocal failed with exit status: 255
alex@ursula ~/devel/test $ autoreconf -fi
configure.ac:8: installing 'build-aux/install-sh'
configure.ac:8: installing 'build-aux/missing'
Makefile.am: installing 'build-aux/depcomp'
alex@ursula ~/devel/test $

*********

Absolutely not a critical one, but first run of autoreconf fails when I
use AX_CXX_COMPILE_STDCXX_14 macro from autoconf-archive (version
2016.03.20-r1 installed via portage on Gentoo), and only when I use it.
Second run immediately after it just works.

The message says "please contact...", so I did.

halfbug.tar.gz (1014 bytes) Download Attachment