Testsuite failure with new Perl

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Testsuite failure with new Perl

Pavel Raiskup
Based on build failure in Fedora 23 [1], automake has some testsuite
failures against newer perl (currently Perl v5.22).  Its because of new
Perl warning:

  $ automake
  Unescaped left brace in regex is deprecated, passed through in regex;
  marked by <-- HERE in m/\${ <-- HERE ([^ \t=:+{}]+)}/ at
  /usr/bin/automake line 3936.

Please consider the attached patch.

[1] https://bugzilla.redhat.com/attachment.cgi?id=1046458
Pavel

0001-bin-automake-escape-in-regexp-pattern.patch (1K) Download Attachment
Loading...